Abgesicherter modus bis classpnp.sys - Falscher Chipsatztreiber

Fragen, Tipps & Tricks zu Windows 7

Moderatoren: coolmann, Aod, chillmensch

Benutzeravatar
Aod
Moderator
Beiträge: 4421
Registriert: 23.03.2004, 16:18
Wohnort: Nordrhein-Westfalen, Tecklenburg
Kontaktdaten:

Abgesicherter modus bis classpnp.sys - Falscher Chipsatztreiber

Beitragvon Aod » 09.06.2018, 07:40

Hallo Zusammen,
hier wieder etwas für das Datengrab "google".

Folgende ausgangs Situation:
Ich habe einen PC mit Asus Mainboard B85-Plus. Dies Mainboard ist leider defekt und nicht mehr Verfügbar. Daher habe ich ein Asus H81M-Plus gekauft. Nach dem Einbau lief erstaunlicher weiße der PC sogar an.

Eigentlich würde ich an dieser Stelle Windows neu Installieren, da es sich um andere Chipsatztreiber handelt. Da aber mehrere Netzwerkpfade, drucker und sonstiges im System hinterlegt sind (die ich nicht hier bei mir habe, ist nicht mein PC) wollte ich Windows nicht neu installieren.

Stattdessen habe ich alles deinstalliert was mit alten Treibern zu tun hatte, und den PC neu gestartet. Soweit so gut.
An dieser Stelle habe ich die Asus Mainboard DVD des neuen Mainboards eingelegt und nur ausgewählte Treiber installiert. Da ich unter Zeit stress war, habe ich nicht nach jeder Treiber installation einen neustart gemacht (was wahrscheinlich der Fehler war) sondern erst am Ende als alle Treiber mit ihrer Setup fertig waren.

Nun hatte ich das Problem das Windows 7 beim Startlogo hängen blieb. Es pulsierte aber der PC machte nicht weiter. Beim Starten des Abgesicherten Modus blieb er dann bei der classpnp.sys Datei hängen. Diese ist für das Starten von Plug & Play Hardware verantwortlich und lädt in meinem Fall wohl beschädigte Treiber.

Da man im Internet nur davon ließt das es mit Hardware defekt zu tun haben soll (kann ich bei mir ausschliesen, da es direkt nach der Chipsatz treiber installation passiert ist) bin ich irgend wann auf eine andere Lösung gekommen. Hier meine Lösung:

Den PC mit "Computer reparieren" starten. (Alternative die Windows 7 DVD einlegen und die Reperatur operationen auswählen.)
Hier kann man nun die Eingabeaufforderung starten. Probiert hier nun aus unter Welchem Laufwerksbuchstaben eure Festplatte mit Windows zu finden ist. Bei mir war es D: . Nun Folgende Befehle ausführen

cd D:\Windows\System32\config
ren system system.backup
cd regback
copy system D:\Windows\System32\config

Dies klappt nur, wenn in eurem Ordner D:\Windows\System32\config\regback auch eine alte Sicherung der System datei liegt. Bei mir war es glücklicherweise eine backup die ein Monat alt ist. Nach anschließendem neustart lief Windows wieder hoch, und man konnte andere Treiber installieren :)

Ich hoffe das hilft mal jemand anderem weiter. Bis dahin
Mfg, Aod
Visit ==> www.Aod1.de.vu <== Wenn du mal ne Abwechslung brauchst ;)

Benutzeravatar
Joyrider
Beiträge: 4473
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Abgesicherter modus bis classpnp.sys - Falscher Chipsatztreiber

Beitragvon Joyrider » 15.06.2018, 21:51

Ergänzung dazu: Die Systemwiederherstellung in Windows muss aktiviert sein und es muss mindestens einen Systemwiederherstellungspunkt geben, damit die Dateien vorhanden sind.


:prost:
Wenn du in die Augen deines Feindes blickst und dich selbst siehst, wie steht es dann um Gnade und Barmherzigkeit?


Zurück zu „Windows 7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast