Heimnetzproblem mit PC und Raspberry Pi

LAN, WLAN, Routing, Netzwerk-Hardware/-Programme und vieles mehr.

Moderatoren: coolmann, chillmensch

Benutzeravatar
Joyrider
Beiträge: 4473
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Heimnetzproblem mit PC und Raspberry Pi

Beitragvon Joyrider » 17.02.2018, 07:06

Ähnlich zu diesem Thema habe ich nun ein neues, für mich unverständliches Phänomen:
netzwerkprobleme-mit-router-interessantes-phanomen-t26994.html

Aktuell ist folgender Stand:
Raspberry Pi: angeschlossen Fritzbox Port 2 (aktuell mit USB-Gigabit-LAN, alternativ mit Onboard-LAN)
PC: angeschlossen an Fritzbox Port 1 (aktuell mit USB-Gigabit-LAN, alternativ mit Onboard-LAN)
Fritzbox: Alle 4 LAN-Ports sind auf Gigabit gestellt, am WAN-Port liegen 100/40MBit VDSL an

Die Verkabelung insgesamt setzt sich wie folgt zusammen (nur Kabel/Switches, kein DLAN mehr):
Raspberry Pi -> Fritzbox -> D-Link Gigabit-Switch -> PC

Folgendes Verhalten (in Megabyte/Sekunde) - Es wurden am PC mit Onboard-LAN und Gigabit-LAN getestet:
Downloads von Internet auf den Raspberry: ca. 12MB/Sekunde
Downloads von Internet auf den PC: ca. 12MB/Sekunde
Downloads vom Raspberry ins Internet: ca. 5MB/Sekunde mit USB-LAN am Pi
Downloads vom PC ins Internet: ca. 5MB/Sekunde
Downloads vom Raspberry auf den PC: ca. 30MB/Sekunde mit USB-LAN am Pi
Downloads vom PC auf den Raspberry: ca. 1-2MB/Sekunde mit USB-LAN am Pi (WTF?) - dies passiert wenn der PC schiebt (via smb oder ftp) oder der Pi ziehen soll via FTP

Das Verhalten lässt sich umgehen:
Nutze ich am Pi die Onboard-Karte, dann kann der PC auch ca. 12MB/Sekunde zum Pi schieben.
Klemme ich einen 100MBit-Switch zwischen den PC und den D-LINK-Switch, dann kann ich auch hier mit ca. 12MB/Sekunde zum Pi schieben.
Schalte ich am PC die Netzwerkkarten auf 100MBit-Fullduplex um, dann klappt es auch einwandfrei.


Hat jemand Erfahrungen mit dem Pi und kann mir dazu was sagen?

In der Regel übertrage ich meist nur Daten vom Pi zum PC, allerdings teste ich ihn grad als MediaServer, daher ist mir das Problem aufgefallen.
Wenn du in die Augen deines Feindes blickst und dich selbst siehst, wie steht es dann um Gnade und Barmherzigkeit?

Benutzeravatar
schmidtsmikey
Site Admin
Beiträge: 8704
Registriert: 08.12.2003, 21:50
Wohnort: Hamburg
Kontaktdaten:

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon schmidtsmikey » 17.02.2018, 19:23

Versuche den Test mal ohne den Switch. Vermute eher, dass das Netzwerk-Routing nicht richtig klappt.

Benutzeravatar
Joyrider
Beiträge: 4473
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon Joyrider » 18.02.2018, 07:08

Das ist Kabeltechnisch schwierig.

Ich kann aber durchaus mal die Ports umstecken und damit mal gegentesten. :)


Edit: Mich wundert dann trotzdem, das es bei 100MBit funktioniert.

Edit 2: Der Switch ist unschuldig, ich habe testweise ein Notebook angeklemmt, damit gehts 1a. Onboard-LAN und auch USB-LAN vom PC geklaut, gleiches Kabel und alles wo sonst der PC dran hängt.
Wenn du in die Augen deines Feindes blickst und dich selbst siehst, wie steht es dann um Gnade und Barmherzigkeit?

Benutzeravatar
schmidtsmikey
Site Admin
Beiträge: 8704
Registriert: 08.12.2003, 21:50
Wohnort: Hamburg
Kontaktdaten:

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon schmidtsmikey » 19.02.2018, 07:44

Ist das eine längere Strecke, die Du verkabelt hast? Sind die Kabel selbst gecrimpt?

In meiner Zeit als Sysadmin hatte ich das Phänomen, dass selbst gecrimpte Kabel mit der Zeit "instabil" wurden. Wenn die Netzwertkkarte das erkennt, schaltet sie automatisch herunter, um einen stabilen Betrieb zu gewährleisten.

Dasselbe passiert, wenn die Kabellänge zu lang ist oder Störquellen (hat vielleicht eine Maus das Kabel angeknabbert?) vorhanden sind.

Benutzeravatar
Joyrider
Beiträge: 4473
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon Joyrider » 20.02.2018, 09:39

schmidtsmikey hat geschrieben:Ist das eine längere Strecke, die Du verkabelt hast? Sind die Kabel selbst gecrimpt?

10m Fritzbox zum Switch und nochmal 10m Switch zu PC.
Selbst gecrimpt: Nein, sind CAT7-SFTP-Kabel.

Habe mittlerweile auch die Lösung, bzw. den Verursacher: Windows 7. Frisch neu installiert, gleiche Macke. Frisches Windows 10 oder Linux: Geht sofort.
Wenn du in die Augen deines Feindes blickst und dich selbst siehst, wie steht es dann um Gnade und Barmherzigkeit?

Benutzeravatar
Jensomio
Moderator
Beiträge: 962
Registriert: 28.08.2005, 12:01
Wohnort: Irgendwo
Kontaktdaten:

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon Jensomio » 20.02.2018, 10:16

Joyrider hat geschrieben:
schmidtsmikey hat geschrieben:Habe mittlerweile auch die Lösung, bzw. den Verursacher: Windows 7. Frisch neu installiert, gleiche Macke. Frisches Windows 10 oder Linux: Geht sofort.


Mir ist aufgefallen, dass Windows 7 nicht mehr richtig funktioniert. Ich denke M$ hat es absichtlich kaputt gepatcht.
Ein Rechner auf dem früher Windows 7 noch tadellos lief, spackt gerade nachdem ich 10 gelöscht und 7 wieder installiert habe, nur noch rum.
Intel® Core™ i7-6800K @4,3 GHz
32GB DDR4 @2400
MSI GTX 980ti
3x 500GB Samsung 850 EVO SSD
Seagate 2TB SSHD
Asus X99 Deluxe II
Corsair 750d Airflow

Benutzeravatar
Joyrider
Beiträge: 4473
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon Joyrider » 21.02.2018, 15:54

Ich hab aktuell keine Lust umzustellen.

Langfristig ist der Umstieg auf Unix/TrueOS geplant, daher ist bei mir grad kein Interesse da den Zwischenweg über Windows 10 oder Debian zu gehen.

Mal schauen.... da ich nur selten Daten auf den Pi schiebe ist das erstmal egal.


Nachtrag und Edit: Nach dem neuesten Update hat Windows 7 mir nun auch die 1070-Grafikkarte gekillt, bzw. den Treiber. Aktuell wird mir sogar verboten, einen neuen Treiber zu installieren und auch den vorhandenen kaputten Treiber zu deinstallieren.
So ungern ich mich der Windows-7-Boykott-These anschließe: Es ist schon arg auffällig, wie Windows 7 sich in der jüngeren Vergangenheit zum Schlechten wandelt, ohne das es offensichtliche Gründe gibt.

Nachtrag 2, ein Bild aus dem abgesicherten Modus:
verweigert.png
Zugriff verweigert
Wenn du in die Augen deines Feindes blickst und dich selbst siehst, wie steht es dann um Gnade und Barmherzigkeit?

Benutzeravatar
Joyrider
Beiträge: 4473
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon Joyrider » 17.03.2018, 18:13

Falls nochmal jemand so ein Problem hat, anbei mein Workaround (das Script als Batch-Datei speichern):

Den Wert "{4D36E972-E325-11CE-BFC1-08002BE10318}" entsprechend durch eure Netzwerkkarte ersetzen.

Code: Alles auswählen

@echo off
for /f "tokens=3" %%i in ('reg query "HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007" /v *SpeedDuplex /t REG_SZ') do (
  if %%i equ 0 goto :set100
  if %%i equ 4 goto :setauto
  goto :end
)

:error
echo "Es ist ein Fehler aufgetreten"
pause
exit

:set100
reg add HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007 /v *SpeedDuplex /d 4 /t REG_SZ /f   
cls
echo "Bitte warten, die Netzwerkkarte wird eingestellt..."
netsh interface set interface "DLAN_onboard" DISABLED 
netsh interface set interface "DLAN_onboard" ENABLED 
echo "Die Netzwerkkarte wurde auf 100 MBit eingestellt!"
goto :end

:setauto
reg add HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007 /v *SpeedDuplex /d 0 /t REG_SZ /f
cls
echo "Bitte warten, die Netzwerkkarte wird eingestellt..."
netsh interface set interface "DLAN_onboard" DISABLED 
netsh interface set interface "DLAN_onboard" ENABLED 
echo "Die Netzwerkkarte auf 1000 MBit eingestellt!"
goto :end

:end
wait 3
ipconfig /release
cls
ipconfig /renew
exit


Die Werte 0 und 4 bei 100 und auto bitte prüfen und bei Bedarf nachjustieren, diese können je nach Netzwerkkarte abweichen, abhängig von den unterstützten Modi.
Wenn du in die Augen deines Feindes blickst und dich selbst siehst, wie steht es dann um Gnade und Barmherzigkeit?

Benutzeravatar
schmidtsmikey
Site Admin
Beiträge: 8704
Registriert: 08.12.2003, 21:50
Wohnort: Hamburg
Kontaktdaten:

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon schmidtsmikey » 20.03.2018, 07:44

Top. Danke für das Feedback!

P.S.: Windows Batch Syntax ist echt grauenvoll :-)

Benutzeravatar
Joyrider
Beiträge: 4473
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon Joyrider » 21.03.2018, 16:46

Es hat seinen Zweck erfüllt.

Ich habe den PC jetzt temporär auf Windows 10 umgestellt und werde in den nächsten Wochen - wenn die Zeit es zulässt - auf Unix migrieren.

Aktuell läuft alles super, von daher hat sich der Aufwand heute wenigstens gelohnt.
Wenn du in die Augen deines Feindes blickst und dich selbst siehst, wie steht es dann um Gnade und Barmherzigkeit?

Benutzeravatar
Joyrider
Beiträge: 4473
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Heimnetzproblem mit PC und Raspberry Pi

Beitragvon Joyrider » 22.03.2018, 13:58

Klappt alles noch besser als gedacht. Mittlerweile fungiert der Pi auch zu Testzwecken als DNS-Server und Werbeblocker.

Das Einzige was schade ist: Die FritzBox erlaubt es bei DHCP nur einen einzigen DNS-Server zu übertragen.

Die Fritzbox soll gerne weiterhin DHCP machen und auch als zweiter DNS-Server fungieren (falls der Pi mal ausfällt).

Hat jemand von euch eine Idee, wie man eine Fritzbox 7590 dazu bringt, einen zweiten DNS zu übertragen?
Wenn du in die Augen deines Feindes blickst und dich selbst siehst, wie steht es dann um Gnade und Barmherzigkeit?


Zurück zu „Netzwerke“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste