Debian langsam im LAN und WLAN

Kernel, Tools, Software, Distributionen, Installation, Treiber, Einstellungen

Moderatoren: coolmann, chillmensch, schmidtsmikey, Yurrderi, Xploder270

Benutzeravatar
Joyrider
Beiträge: 4386
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Debian langsam im LAN und WLAN

Beitragvon Joyrider » 30.03.2014, 18:23

Ich habe hier zu Hause das Problem das mein Laptop mit Debian (Jessie) im LAN und WLAN sehr langsam ist. Übertragungsmäßig kommen da 100-200KByte/Sekunde zusammen.

Mit Windows 7 auf dem gleichen Laptop habe ich das Problem nicht.

Der PC und ein anderer Laptop sind auch fix unterwegs.

Und jetzt kommt das ABER:
Ich war letztens im Urlaub und dort gab es ein Hotel-WLAN. Verbindung war gut, die Übertragung waren ca. 900-1000KByte/Sekunde. Nun frage ich mich aber: Wie kann es sein das nur hier zu Hause die Geschwindigkeit so einbricht? Ob LAN oder WLAN ist egal, es ist ca. gleichmäßig träge.

Kann es eine Inkompatiblität von Router und Debian sein? Ich habe auch die WLAN-Verschlüsselung vermutet, aber im LAN (mit Kabel direkt am Router) dürfte das ja keine Rolle spielen.

Und das Eigenartige: Mit Windows 7 gibt es das Problem nicht. Und das verstehe ich nicht.
Familie ist nicht das, wo man hineingeboren wird, sondern das, wofür man stirbt.

Benutzeravatar
schmidtsmikey
Site Admin
Beiträge: 8651
Registriert: 08.12.2003, 21:50
Wohnort: Hamburg
Kontaktdaten:

Re: Debian langsam im LAN und WLAN

Beitragvon schmidtsmikey » 30.03.2014, 20:19

Tja. Da hilft nur ausprobieren. Wenn du den Router in Verdacht hast, kannst du einfach die Datenübertragung mit einem anderen Hub ausprobieren. Dad wäre mein Tipp. Ziemlich special das Problem.

Benutzeravatar
Joyrider
Beiträge: 4386
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Debian langsam im LAN und WLAN

Beitragvon Joyrider » 13.04.2014, 17:44

Lag vermutlich am Kernel.

Neuen Kernel kompiliert, Problem gelöst.
Familie ist nicht das, wo man hineingeboren wird, sondern das, wofür man stirbt.

Benutzeravatar
Joyrider
Beiträge: 4386
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Debian langsam im LAN und WLAN

Beitragvon Joyrider » 01.06.2014, 11:18

Ok, das es ging war Zufall.

Ich habe das Problem eben wieder gehabt und kann es nun re-produzieren:
- Sobald das Laptop am Ladekabel hängt bricht die Geschwindigkeit ein.
- Wenn ich das Kabel ziehe habe ich wieder die normale Geschwindigkeit.

Eben getestet mit einer FTP-Verbindung.

Also ist da wohl was mit dem Energiesparmodus.
Familie ist nicht das, wo man hineingeboren wird, sondern das, wofür man stirbt.

Benutzeravatar
Joyrider
Beiträge: 4386
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Debian langsam im LAN und WLAN

Beitragvon Joyrider » 02.06.2014, 13:14

Noch ein Update:
In Windows 7 das gleiche Phänomen: Netzkabel ran (Akkustand egal), WLAN wird langsam.

Dann kommt noch die Meldung das der Netzwerkadapter (LAN) nun sicher entfernt werden kann.
Familie ist nicht das, wo man hineingeboren wird, sondern das, wofür man stirbt.

Benutzeravatar
schmidtsmikey
Site Admin
Beiträge: 8651
Registriert: 08.12.2003, 21:50
Wohnort: Hamburg
Kontaktdaten:

Re: Debian langsam im LAN und WLAN

Beitragvon schmidtsmikey » 02.06.2014, 17:44

Boah du hast aber immer Probleme, Du?! Meine Tendenz ist eher eine BIOS-Einstellung, wenn es unter Linux und Windows auftritt.

Oder hast Du mit beiden eine Verbindung? Dann kann es zu Routing-Problemen kommen, denn das System weiß nicht, über welches Interface es die Verbindung aufbauen soll... Schalte mal die WLAN-Karte aus, wenn das LAN-Kabel angesteckt wird.

Benutzeravatar
psico
Beiträge: 1950
Registriert: 28.09.2005, 18:20
Wohnort: Zebulon

Re: Debian langsam im LAN und WLAN

Beitragvon psico » 03.06.2014, 05:20

Vielleicht ein Hardware defekt am Gerät?
Wer immer in Richtung Osten geht, wird im Westen ankommen...

| CPU: AMD Ryzen 7 1700x | MB: GA B350 WiFi mITX | RAM: G.Skill 16GB DDR3000 Kit | GPU: KFA² GTX 1080 | SSD: Samsung 250GB & Samsung 500GB | Case: Fractal Node 304 White | Displays: 24" & Dell 34" & 24" | AiO WaKü | OS: W10 | 3TB NAS |

Benutzeravatar
Joyrider
Beiträge: 4386
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Debian langsam im LAN und WLAN

Beitragvon Joyrider » 05.06.2014, 18:06

Ich konnte das Phänomen aber an diversen Geräten (haben davon in der Firma ja genug) gegentesten.

Was auch geil ist: Wenn man die Dinger lädt spinnt bei einigen das Touchpad. Im Akkubetrieb kein Problem.

Bezüglich LAN und WLAN: Die waren immer getrennt. Wenn LAN ist ist WLAN aus und umgekehrt.

Und dadurch das ich das Laptop im Urlaub NICHT am Netzkabel hatte gab es auch nicht das Problem mit der Langsamkeit.


Bezüglich BIOS: Kann auch gut sein. Ist nur ein billiges HP-BIOS, wo man nicht allzuviel einstellen kann. Hardwaredefekt denke ich weniger, eventuell nur irgendwelche Kompatibilitätsprobleme.

Ich mache gleich nochmal den ultimativen Gegentest. Betrieb mit Netzkabel, Akku dabei nicht im Gerät.
Familie ist nicht das, wo man hineingeboren wird, sondern das, wofür man stirbt.


Zurück zu „Linux“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste