Windows 7 - 100% Last wegen Windows Update

Fragen, Tipps & Tricks zu Windows 7

Moderatoren: coolmann, Aod, chillmensch

Benutzeravatar
Joyrider
Beiträge: 4327
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Windows 7 - 100% Last wegen Windows Update

Beitragvon Joyrider » 19.05.2015, 18:19

Ich hab hier ein Notebook, Windows 7 Professional inkl. SP1 frisch installiert.

Windows Update auf "Keine Suche" gestellt und dann händisch nach Updates suchen lassen. Seit über 45 Minuten sucht das sch*** Ding nun und hat 100% CPU-Last mit der svchost.exe.

Das Problem gibts seit XP und auch Windows 8.1 hat es noch.

Kann mir jemand sagen woher das kommt? Einen Virus schließe ich aus, da Windows 7 komplett frisch ist.

Mir ist klar das es nur am Anfang auftritt, nur möchte ich gern wissen warum.
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 + AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD

Benutzeravatar
Joyrider
Beiträge: 4327
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Joyrider » 28.05.2015, 10:38

Hat keiner ne Idee?

Habe nun schon Kiste 4 und immer noch das gleiche Problem.

Jedes Mal frisches Windows 7 und es sucht und sucht und sucht.

Ich verstehe nicht das Microsoft das nicht hinkriegt.
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 + AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD

Benutzeravatar
schmidtsmikey
Site Admin
Beiträge: 8534
Registriert: 08.12.2003, 21:50
Wohnort: Hamburg
Kontaktdaten:

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon schmidtsmikey » 30.05.2015, 16:00

Neues Windows 7? Ich kenne das Problem, dass es eine gefühlte Ewigkeit dauern kann. Wenn Du Probleme mit Deiner Firewall/Internetverbindung ausschließen kannst, lass Windows einfach mal die Updates machen.

Benutzeravatar
Joyrider
Beiträge: 4327
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Joyrider » 31.05.2015, 10:23

Die Updates sind ja das Problem. ;)
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 + AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD

Benutzeravatar
Andy_20
Beiträge: 3920
Registriert: 23.04.2004, 10:56

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Andy_20 » 31.05.2015, 10:35

Also mit Win 8.1 kann ich das definitiv nicht bestätigen das 45min nach Updates gesucht wird nachdem neu installiert wurde, das installieren von allen inkl. Office dauert in etwa solange (auch mit SSD). Und da ist doch eigentlich gut das der CPU zu 100% ausgelastet wird damit das nicht noch länger dauert.
Dein Problem wird sein das zwar manuelles Updaten aktiviert wurde, aber Windows trotzdem beim ersten Start und vorhandenen Inet sofort Updates installiert. Startest du jetzt noch manuell über Windows Update die Suche dauert das so ewig, weil er noch hunderte Updates im Hintergrund verarbeitet. Macht man einfach nochmal einen Neustart sieht man das er Updates installiert hat.
MfG Andy
Bild

Benutzeravatar
Joyrider
Beiträge: 4327
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Joyrider » 01.06.2015, 07:00

Nochmal im Klartext:

- Windows 7 wurde frisch installiert (diverse Computer)
- Die Windows-Updates wurden deaktiviert (nur manuelle Installation)
- Die Suche nach Updates wird manuell gestartet (ab hier treten 100% Last auf und es dauert teils bis zu 60 Minuten)
- Die Installation der Updates, nachdem sie dann gefunden wurden klappt reibungslos, die Last ist hier wieder normal und bei maximal 50% (soweit auch alles ok)

Ich verstehe nur nicht wieso Windows 7 sich plözlich so abrackert. Ich setze diverse PCs neu auf, die Probleme treten erst seit kurzer Zeit auf. Die Installations-DVD ist die Gleiche. Und die Computer sind teils neu und teils gebraucht. Das alle defekt sind schließe ich aus.
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 + AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD

Benutzeravatar
Takato
Beiträge: 1913
Registriert: 07.01.2005, 12:06

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Takato » 01.06.2015, 21:12

Ich könnte mir vorstellen, dass es daran liegt, das deine CD selbst mit SP1 immernoch 4 Jahre alt ist und er eine Menge auf dem System untersuchen muss, was er denn nun jetzt patchen muss und was nicht. Probiers mal mit einer eigenen windows 7 CD wo du die updates integrierst.

Benutzeravatar
Joyrider
Beiträge: 4327
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Joyrider » 02.06.2015, 07:17

Ja, das wäre eine Lösung. Nur interessiert mich ja die Ursache.

Windows muss doch jetzt auf dem System genausoviel untersuchen wie vorher. Oder meinst du das es durch die hohe Menge an Updates kommt die zur Verfügung stehen? Das wäre natürlich eine Möglichkeit.
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 + AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD

Benutzeravatar
Zuujin
Moderator
Beiträge: 1484
Registriert: 28.12.2004, 03:40
Wohnort: Hessen

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Zuujin » 02.06.2015, 13:41

Moin,

Windows' "Paketmanagement" war noch nie sonderlich gut. Ich kenne das Phänomen leider auch. Eine Lösung, außer "Ach, lass ihn halt arbeiten", hab ich allerdings auch nicht, dafür tritt bei mir die Notwendigkeit für Updates der letzten Jahre zu selten auf^^
Auch nervt mich, dass es mit einmal Update drücken nicht getan ist, da diverse Updates erst gefunden werden, sobald andere installiert wurden und manche fehlschlagen, weil es durch anderes obsolet wurde.
Vielleicht ist Windows' Paketmanagement auf nem Bruteforce-Algorithmus aufgebaut, und durch die Masse an neuen Updates braucht er fürs sortieren halt ne Weile...

Gruß,
Zuujin
"Weißt Du, das blöde am echten Leben ist, dass es keine Gefahrenmusik gibt." -Cable Guy

Benutzeravatar
Joyrider
Beiträge: 4327
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Joyrider » 03.06.2015, 14:17

Es gibt ja Updatepacks usw, nur will ich die Lösung nicht nutzen.

Aktuell teste ich grad das neue nlite und werd damit mal versuchen mir ne Windows 7 SP1 DVD zu bauen wo schon viele Updates drin sind. Vielleicht hilfts.
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 + AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD

Benutzeravatar
lueftermeister
Moderator
Beiträge: 4576
Registriert: 04.12.2003, 20:28
Wohnort: Düsseldorf
Kontaktdaten:

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon lueftermeister » 01.01.2017, 21:48

Ich muss mal den alten Thread aus dem Grab holen. Da ich in den letzten Monaten einige PCs neuinstalliert habe und das Updateproblem bei allen auftrat, habe ich mal etwas gesucht. Nach dieser Anleitung -Link- und -Link- (mit einem Update-Pack) habe ich die Updates installiert und siehe da: es läuft. Es konnte bisher nur ein PC bearbeitet werden, in den nächsten Tagen folgt mein eigener :) Das Update-Pack von DrWindows lief nicht ganz rund. Nach 30 Minuten Stillstand vom Fortschrittsbalken habe ich mal weiter nachgeforscht. Man muss Win herunterfahren aber den Vorgang abbrechen. Danach hat sich das Updatefenster aktualisiert (es wurde ein Neustart verlangt). Nachdem man neustartete liefen die restlichen Updates ohne Probleme durch. svchost.exe verhielt sich ganz ruhig und es wurden Win-Updates normal gefunden und installiert.

luefty
besuch pc-erfahrung.de im Chat

Intel Core i7 6700 Skylake; Thermalright HR-02 Macho Rev.A; Gigabyte GA-Z170-HD3P; Sapphire Radeon RX470 8 GB DDR5; 2x 8 GB Corsair Vengeance LPX schwarz DDR4-3000; 120 GB Samsung 850 EVO, 1 TB Seagate 64 MB Cache, 500 GB Samsung 16MB Cache; Chieftec Smart CH-09B-B; Be Quiet! BQT E6-450W

Benutzeravatar
schmidtsmikey
Site Admin
Beiträge: 8534
Registriert: 08.12.2003, 21:50
Wohnort: Hamburg
Kontaktdaten:

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon schmidtsmikey » 03.01.2017, 02:23

Danke für den nützlichen Tipp...

Booster365
Beiträge: 3
Registriert: 20.08.2017, 19:25

Re: Windows 7 - 100% Last wegen Windows Update

Beitragvon Booster365 » 20.08.2017, 19:28

lueftermeister hat geschrieben:Ich muss mal den alten Thread aus dem Grab holen. Da ich in den letzten Monaten einige PCs neuinstalliert habe und das Updateproblem bei allen auftrat, habe ich mal etwas gesucht. Nach dieser Anleitung -Link- und -Link- (mit einem Update-Pack) habe ich die Updates installiert und siehe da: es läuft. Es konnte bisher nur ein PC bearbeitet werden, in den nächsten Tagen folgt mein eigener :) Das Update-Pack von DrWindows lief nicht ganz rund. Nach 30 Minuten Stillstand vom Fortschrittsbalken habe ich mal weiter nachgeforscht. Man muss Win herunterfahren aber den Vorgang abbrechen. Danach hat sich das Updatefenster aktualisiert (es wurde ein Neustart verlangt). Nachdem man neustartete liefen die restlichen Updates ohne Probleme durch. svchost.exe verhielt sich ganz ruhig und es wurden Win-Updates normal gefunden und installiert.

luefty


Danke geholfen)


Zurück zu „Windows 7“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste