Debian-Netinstall mit Vaio-Notebook: Bei Installation wird keine WLAN-Firmware erkannt (Intel Wireless-AC 7260)

Kernel, Tools, Software, Distributionen, Installation, Treiber, Einstellungen

Moderatoren: coolmann, chillmensch, Xploder270, schmidtsmikey, Yurrderi

Benutzeravatar
linkin_park_forever
Moderator, hieß früher "vs"
Beiträge: 5815
Registriert: 13.03.2004, 21:15
Wohnort: München

Debian-Netinstall mit Vaio-Notebook: Bei Installation wird keine WLAN-Firmware erkannt (Intel Wireless-AC 7260)

Beitragvon linkin_park_forever » 26.03.2017, 17:19

Hi zusammen,

ich will Debian auf meinem Vaio zum Laufen bringen. Habe dazu mit unetbootin einen USB-Stick mit einer aktuellen Debian Netinstall-ISO erstellt. Dann von UEFI auf Legacy umgestellt und vom Stick gebootet- funktioniert soweit. Die Installation mittels GUI funzt bis zu der Stelle, an der die WLAN-Firmware nicht gefunden wird (Intel Dual Band Wireless-AC 7260). Die Installation fordert mich dann auf, zwei Firmware-Dateien per USB-Stick einzuspielen. Habe diese daraufhin runtergeladen (iwlwifi-7260-8.ucode und iwlwifi-7260-9.ucode) und einfach auf den Debian-Stick kopiert. Wenn ich dann aber auf "continue" klicke, findet die Installation die Firmware nicht. Wenn ich den WLAN-Treiber überspringe, kommt als nächstes, dass kein Ethernet gefunden wurde- was ja auch korrekt ist, da das Notebook keinen Port dafür hat.

Da es aber eine Netinstall ist, bin ich quasi auf die WLAN-Firmware angewiesen, da sonst mittendrin die Installation nicht mehr weitergeht.

Wie kann ich denn die .ucode-Files während der Installation laden/einbinden? Hätte ich sie besser auf einen gänzlich leeren USB-Stick kopieren sollen?

Danke!
Desktop: Zen auf mITX-AM4 in Planung
Notebook: Sony Vaio 13 Pro, Core i5 4200U, 4 GB DDR3, FHD IPS matt
Smartphone: Motorola Moto X 2nd Gen

Benutzeravatar
Joyrider
Beiträge: 4271
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Debian-Netinstall mit Vaio-Notebook: Bei Installation wird keine WLAN-Firmware erkannt (Intel Wireless-AC 7260)

Beitragvon Joyrider » 01.04.2017, 08:10

linkin_park_forever hat geschrieben:Wie kann ich denn die .ucode-Files während der Installation laden/einbinden? Hätte ich sie besser auf einen gänzlich leeren USB-Stick kopieren sollen?

So habe ich das bisher mit meinen WLAN-Treibern gehandhabt, hat gut funktioniert.

Also ja, probier das bitte mal aus, dann sollte es klappen.
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 / AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD - und ein Schweizer Messer!
The code is: 7355608

Benutzeravatar
linkin_park_forever
Moderator, hieß früher "vs"
Beiträge: 5815
Registriert: 13.03.2004, 21:15
Wohnort: München

Re: Debian-Netinstall mit Vaio-Notebook: Bei Installation wird keine WLAN-Firmware erkannt (Intel Wireless-AC 7260)

Beitragvon linkin_park_forever » 02.04.2017, 16:12

Dürfte reichen, wenn der Stick FAT32-formatiert ist? Oder muss man da beim Dateisystem auf was achten?
Desktop: Zen auf mITX-AM4 in Planung
Notebook: Sony Vaio 13 Pro, Core i5 4200U, 4 GB DDR3, FHD IPS matt
Smartphone: Motorola Moto X 2nd Gen

Benutzeravatar
Joyrider
Beiträge: 4271
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Debian-Netinstall mit Vaio-Notebook: Bei Installation wird keine WLAN-Firmware erkannt (Intel Wireless-AC 7260)

Beitragvon Joyrider » 04.04.2017, 16:22

FAT32 geht, unter Windows sind deine Möglichkeiten ja eh begrenzt. ;)

Falls der Stick zu groß ist: h2format ist ein sehr feines Tool.
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 / AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD - und ein Schweizer Messer!
The code is: 7355608

Benutzeravatar
linkin_park_forever
Moderator, hieß früher "vs"
Beiträge: 5815
Registriert: 13.03.2004, 21:15
Wohnort: München

Re: Debian-Netinstall mit Vaio-Notebook: Bei Installation wird keine WLAN-Firmware erkannt (Intel Wireless-AC 7260)

Beitragvon linkin_park_forever » 17.04.2017, 01:26

Es hat leider nicht funktioniert. Habe aber vermutlich die falschen .ucode-Dateien auf den Stick getan. Bei Intel gab es nämlich neuere bzw. aktuellere Versionen der WLAN-Firmware, das Setup verlangte aber explizit nach älteren Files. Die neueren wurden nicht erkannt bzw. es passierte gar nichts. Im Endeffekt hatte ich das Debian-Setup dann so weit bekommen, dass es die Ethernet- und WLAN-Installation überspringt, aber booten konnte es trotzdem nicht :? Am Ende war der Bootloader hinüber und es ging nur noch die Grub-Kommandozeile. Nach längerem Hin und Her konnte ich dann mit einem bootfähigen Windows-ISO den Bootloader wiederherstellen.

Vorläufiges Fazit: Schei*e.

Also ich würde es gerne zum Laufen kriegen, aber es ist echt kein Leichtes. Google-Recherche ergab, dass es mit den Vaios auch nicht wirklich easy ist, ein Linux sauber aufzusetzen. Immerhin lief die Ubuntu-Installation ohne Probleme durch- selbst die WLAN-Treiber wurden automatisch installiert.

Sobald die neue Ubuntu-Gnome-ISO verfügbar ist, werde ich einen neuen Anlauf starten.
Desktop: Zen auf mITX-AM4 in Planung
Notebook: Sony Vaio 13 Pro, Core i5 4200U, 4 GB DDR3, FHD IPS matt
Smartphone: Motorola Moto X 2nd Gen

Benutzeravatar
Joyrider
Beiträge: 4271
Registriert: 27.09.2006, 08:45
Wohnort: 127.0.0.1

Re: Debian-Netinstall mit Vaio-Notebook: Bei Installation wird keine WLAN-Firmware erkannt (Intel Wireless-AC 7260)

Beitragvon Joyrider » 23.04.2017, 09:49

Gibt es noch andere Treiber/Firmware außer den ucode-Dingern?

Hast du hier mal geschaut?
https://www.debian.org/releases/stable/ ... 04.html.de

Ich hatte so ein Problem mit Realtek, da hab ich mir die Firmware runtergezogen und es ging sofort.
AMD FX-8350 (8x 4GHz) - 32 GB RAM (4x 8GB DDR3) - NVIDIA 1070 / AMD 6970 - 500GB SSD / 2TB HDD / 3TB HDD - und ein Schweizer Messer!
The code is: 7355608


Zurück zu „Linux“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste